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INTRODUCTION

The exercise will show how to model compressible and supersonic fluid flow. The
issue will be presented on the example of the flow around the NACA2418 airfoil. The
airfoil with a chord length of 1 m is flowed in air at a temperature of 20 °C. The flow is
carried out for three Reynolds numbers: 50,000, 500,000 and 5,000,000. The diagram of
the analyzed case is presented in Fig. 1.
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Fig. 1. Scheme of the flow around NACA2418 airfoil



2. FLOW AROUND NACA2418 AIRFOIL
2.1. GEOMETRY
Do the following:

1) Open Ansys Workbench and save project as Ex7 in catalog Ex7 (File->Save

As).

RULE OF THUMB No. 1: Create a separate catalog for each project
RULE OF THUMB No. 2: In directory names, do not use: spaces, special

characters (e.g. @ # $% " & * etc.
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2) Select the Mesh module and open Spaceclaim. To do this, hold the left mouse
button (LMB) on the Mesh module and drag it to the Project Schematic field.
Then double-click LMB on Geometry to start the Spaceclaim program in which
the geometry will be created. Note that in the lower left corner of the screen
there is an inscription informing what program is running.
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3) In Assembly tab select File, and then point to the file attached to the exercise

4)

-

NACA2418.txt
Design Display Measure Facets Repair Prepare Workbench Detail Sheet Metal Tools
S ‘HA (-)|JC—H
File fStandard
Patr <7 & v <« WZPCP » D » Cw7 v O Przeszukaj: Cw7
Part
Organizuj * Nowy folder =
Design1 * Pobrane ~ O Nazwa Data modyfikagji
B Pulpit Cw7_files backup 12052020 14:54
B wideo w7 files 12052020 14:54
i 0S(C) i Cw7 12.05.2020 14:54
’ W .
Layers Selection Groups M| == Dysk lokalny (D) i CwT 12.05.2020 1437
_ ) Stacja dyskéw CL |=] NACA2418 12.05.2020 14:16
slection
= MAGAZYN (F)
in sketch connectivity = MAGAZYN (F)
Trash-1000
i KompPraca
o gnd
OF1606_BEM
o angle
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Options...

Nazwa pliku: NACA2418 ~ | All Files (**)
Otworz

Click LMB Select New Sketch |ﬁ,| to choose sketching plane.

(o](m) 2][®]
— Select New Skeich Flane

E Click an object to cnent the
skeich grid along the obgect

) Press F1 for mone help.

Select the X-Y plane as shown below.
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5) Click Plan View |—J to rotate the drawing plane parallel to the screen (you
can also do this by pressing Shift + v).

o=)4) =

' Plan View (V)
Display your design 50 that you are viewing the
x=5.9589 y= = guahelam :
¥ Press F1 for more help, or F3 for a video.

6) In the panel at the top of the screen, select the line drawing icon ™ and draw
a line near the trailing edge of the profile to close it.
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Remember that if you fail at any time, you can click the undo icon -
(located in the upper left corner of the screen) or Ctrl + z.

7) To exit the line drawing command, press Esc and LMB, click the Return to 3D
mode icon at the bottom of the screen.

[o]=](2)=)
Retum to 3D mode

0 Activate the Pull tool in 3D
mode.

& Press F1 for more help.

8) In Design tab, select Fill, and then select the entire profile by dragging LMB
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ANSYS

_______

__________________________________________________________________

9) Select Complete

Cap planar region with a surface
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v

Complete (Enter)

Complete the Fill
J operation.
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10) Select the plane to draw the sketch on one of the side surfaces of the profile

2020 R1
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12) Draw a circle with a diameter of 12000 mm hooked at the right end of the line



Snapping to Grid
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13) Draw a line 12000 mm long above the profile and tangent to the circle



Snapping to Tangent to Curve, Parallel to Grid, Dimension Value

b [o)(m]2]s]

I\ Design1® x

14) Create a similar line under the profile



napping to Dimension Value, Parallel to Grid, Parallel to Curve, Tangent to Curve

v

15) Close profile
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16) Select the Trim away icon and remove the red circle marked by pointing to it

LMB
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17) Point to LMB the line yo|u-no Ionéer need inside the profile and press the Delete
key

Select 1 sketch curve

ANSYS

2020 R1
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18) Return to the 3D view and select the Pull command, and then pull out the
created profile by 200 mm.
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19) LMB point to the profile and press Delete to delete it.



20) In the exercise, a hexagonal mesh will be created. To create it, you need lines
that will designate individual grid "blocks". We will use the icon to create them

Split in Design tab. After selecting it, indicate a large, flat surface
marked in yellow



Click on a face to be split

I\ Design1* x
21) Move the cursor to the trailing edge and select the top vertex - an intersection is
created




22) Do the same with the bottom vertex - if there is no blue background with a
visible intersecting line, make sure that the option Select UV cutter point is

selected
Click a point on an edge to split from

s

-

&
Y
... - X
-
Nsys x 4 b x
23) Then select the plane below and the vertex from the part of the circle
x| ANSYS |
2020 R1

24) Similarly, create an intersection under the profile



Click a point on an edge to split from

’ v
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25) Similar cutting edges should be made on the other side of the geometry. This
can be done by the previous method or the following method using the
command Project
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Project

Q Select a face, surface, edge, or

note text to project its edges
perpendicularly. Alt+click
another face or edge to set the
projection direction.

o Press F1 for more help.
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26) While holding down the Ctrl key select previously created edges



Select 1 or more faces or lines to project
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27) Select the projection direction by pointing to the flat surface



Pick a direction to project in
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28) Select a large flat surface as the projection plane and confirm Complete



Pick faces to limit the projection to. Exit the tool to finish the

o

29) Close Spaceclaim and save project in Workbench using Ctrl + s

2.2. NUMERICAL MESH
1) Open Ansys Meshing by double-click LMB Mesh
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2) In Ansys Meshing: 1) click Mesh, 2) change Physisc Preference into CFD, 3)
change Solver Preference into CFX, 4) click LMB Generate Mesh
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[=| Defaults
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Sizing
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Advanced
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The default mesh is not valid. The mesh should be edited.
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3)

0,000 5,000 10,000 ()

Messages
| Association

Error
Error

Error

Text
One or more entities failed to mesh. The mesh of the bodies containing these entities may not be up-to- Project>Model>Geometry>SYS Bodies>SYS\Solid

One or more surfaces cannot be meshed with acceptable quality. Try using a different element size or vir Project>Model>Geometry>SYS Bodies>SYS\Solid

| A mesh could not be generated using the current meshing options and settings. Project>Model>Mesh

Click right mouse button (RMB) on Mesh and select Insert->Method
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H] Advanced @ Node Move
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Control the algorithm and mesh types used to generate meshes on scoped entities.
4) LMB indicate the whole body and confirm Apply in Geometry
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Scope
Scoping Method | Geometry Selection
eome Apply Cancel
Definition
Suppressed No
Method Automatic

Element Order Use Global Setting




5) Apply the following settings

6) Click RMB on Mesh and select Insert->Sizing

Name ¥ | Search Outline | ™

7)

I Project*
----- Model (A3)

Bl @ Geometry
/{8 Materials
B, 24 Coordinate Systems

oo I
S

B2
2

tails of "Mesh"
Display

Display Style
Defaults ¥
Physics Preference &
Solver Preference 4>
Element Order aIb
Element Size

Sizing

Insert
Update

Generate Mesh

Preview

Show

Create Pinch Controls
Group All Similar Children
Clear Generated Data

Rename

Start Recording

Details of "MultiZone" - Method ~ 00O

Scope

Scoping Method Geometry Selection

Geometry 1 Body

Definition

Suppressed No

Method MultiZone

Mapped Mesh Type Hexa/Prism

Surface Mesh Method Program Controlled

Free Mesh Type Not Allowed

Element Order Use Global Setting

Src/Trg Selection Automatic

Source Scoping Method | Program Controlled

Source Program Controlled

Sweep Size Behavior Sweep Element Size
Sweep Element Size | Default

-
£
&

J'“( =y
= g

F2

Quality

Inflation

Advanced

Statistics

Change the selection filter to edgTes (shortcut Ctrl + E) and point to the edge as

shown below
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Sizing

'

Face Mesh
Mesh Cop

Control size-related settings such as element
size, number of divisions along an edge, use of
sphere or body of influence, minimum size, etc.

Match Cor
Pinch

(D Press F1 for help.

Inflation
Mesh Edit
Mesh Numbering

Contact Match Group
Contact Match

Node Merge Group
Node Merge

Node Move
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8) Apply the following settings

=

Details of "Edge Sizing" - Sizing v3Ox
Scope
Scoping Method Geometry Selection
Geometry 1 Edge
Definition
Suppressed No
Type Number of Divisions
| Number of Divisions | 150
Advanced
Behavior m
Capture Curvature No
Capture Proximity No
Bias Type oo
Bias Option Bias Factor
| Bias Factor 100, |
Reverse Bias No Selection

Blree® ® =2 B

9) Similarly, insert Sizing for the edges at the trailing edge shown below



10) Apply the following settings

Scope
Scoping Method - Geometry Selection
Geometry 2 Edges
Definition
Suppressed No
Type Number of Divisions
Number of Divisions hl
Advanced
Behavior Hard
Capture Curvature No
Capture Proximity No
- Bias Type ' No Bias

And press Generate Mesh.

11) The last step is to name the volumes and surfaces. Give the following names
using Create Named Selection (if you do not remember how to use Create
Named Selection, check the previous instructions):

a. Whole volume — Fluid_domain

b. Inlet surface (cylindrical surface) — inlet



c. Symmetry surfaces (on both sides) — sym

2,500

d. Area of the airfoil — airfoil

e. Outlet surface (other surfaces) — outlet
12) Close Ansys Meshing and save project in Workbench.



2.3. NUMERICAL MODEL
1) Insert CFX

| B Analysis Systems A prmmssmmssmse———— ]
E Design Assessment
Eigenvalue Buckling
8] Electric

BN Explicit Dynamics
& Fluid Flow (CFX)
{3 Fluid Flow (Fluent)
k] HarmonicAcousts
(¥ HarmonicResponse i H
ﬁ IC Engine (Fluent) e e
@ Magnetostatic

B Modal

Bl Medal Acoustics

il Randemvibration
El Response Spectum
ﬁ Rigid Dynamis

Ll staticAcoustis

B3 Static Structural

) Steady-State Thermal
) Thermal-Elactric

(£ Topology Optimization
fzd Transient Structural
Transient Thermal 1
@ Turbomachinery Fluid Flow

[Eﬂumpnnentﬁ'sm |
iy AcCP (Post)
iy ACP (Pre)
fid BladeGen /
[® = 7]
g Engineering Data
ﬂ External Data
g Sxternal Model

Flugnt

Fluent (with EMent Meshing)
B Geometry
To connect the Mesh module with CFX, grab the LMB Mesh (below) and drag

it to Setup until the Transfer A3 box appears, and then release the LMB - the
connection has been created

- A b 4
1 1
2

=
1
2 Geometry " Create standalone system
3

Z Geometry " Transfer A3
3@ Mesh v ] 3 @3 soluton P
Mesh 4 @ Resus 7
CFX

Click RMB on Mesh and choose Update



Geometry "

2
3| @ Mesh

Mesh

Duplicate
Transfer Data From Mew »
Transfer Data To New 3

Update

Update Upstream Components
Clear Generated Data

Refresh

Reset

Rename

Properties

Quick Help
Add Mote

Double-click Setup to run Ansys CFX
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Bl cigenvalueBuckling
[8) Electric
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B Static Structural
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g Engineering Data
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E? Fluent
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B 1cemcFD

i@ Material Designer
I\ Mechanical arDL
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ﬁ Mesh

[ Microsoft OfficeExcel
€5 Performance Map
& Results

System Coupling
&3 Turho Setup

B vista AFD
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Mesh
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2) Open Analysis Type by double-click LMB



hd [EI Mesh
& sys.cmdb
5| Connectivity
hd @ Simulation
~ [ Flow Analysis 1
v || Default Domain
M ¥ Default Domain Default

Apply the following settings and confirm OK.

Outline Analysis Type
Details of Amalysis Type in Flow Analysis 1

Basic Settings
AMSYS MultiField Coupling

Option Maone

Analysis Type

Optian Steady smg

3) Double-click LMB Default Domain
¥ @ Mesh

&1 sys.cmdb
G Connectivity
hd [EI Simulation
v [ Flow Analysis 1

(D Analysis Type

b Default Domain

[“19% Default Domain Default

i:ﬂ Interfaces

Apply the following settings




Outline  Domain: Default Domain
Details of Default Domain in Flow Analysis 1

Basic Settings | Fluid Models  Initialization = Solver Control

Location and Type

Location |FIuid_domain | v
Domain Type Fluid Domain -
Coordinate Frame Coord 0 -
Fluid and Particle Definitions... =)
Fluid 1
L]
X
Fluid 1 =
Option Material Library -
Material |] Air Ideal Gas | ~
Morphology B
Option Continuous Fluid -
(] Minimum Volume Fraction

Domain Models
Pressure =

Reference Pressure \1 [atm]

Outline Domain: Default Domain
Details of Default Domain in Flow Analysis 1

Basic Settings | Fluid Models | Initialization  Solver Control

Heat Transfer S|

Option Total Energy -

Incl. Viscous Work Term

Turbulence =
Option Shear Stress Transport -
Wall Function Automatic -

[ High Speed (compressible) Wall Heat Transfer Model
] Blended Near Wall Treatment (Beta)
[] Turbulent Flux Closure for Heat Transfer
[] Transitional Turbulence
Advanced Turbulence Control

HEHEA

Combustion =
Option None -
Thermal Radiation =]
Option None -

] Electromagnetic Model =



4) Create expression named Re with a definition
Details of Re

Definition Plot Evaluate

50000|

5) Create expression named chord with a definition
Details of chord

Definition Plot Evaluate

1/mj

6) Create expression named ulnlet with a definition
Details of uInlet

Definition Plot Evaluate

Re™ Dynamic Viscosityf choxd/ Density

7) Create boundary condition inlet

= = 72 1,

Insert Bound...

Mame |inleﬂ

8) Apply the following settings

Qutline Boundary: inlet
Details of inlet in Default Domain in Flow Analysis 1

Basic Settings Boundary Details Fluid Values Sources Plot Options

Boundary Type I Inlet I

Location I inlet I

[] Coordinate Frame



Qutline  Boundary: inlet
Details of inlet in Default Domain in Flow Analysis 1

Basic Settings | Boundary Details | Sources  Plot Options

Flow Regime B
Option Subsonic -
Mass And Momentum B
Option Cart. Vel. Components A

U ulnlet |

v 0[ms™-1] |

w 0[ms™1] |

[] Acoustic Reflectivity (Beta)

Turbulence =]
Option Medium (Intensity = 5%) -

Heat Transfer B
Option Static Temperature -

Static Temperature 20 [C] |

9) Create boundary condition outlet and apply the following settings
Qutline  Boundary: outlet
Details of outlet in Default Domain in Flow Analysis 1

Basic Settings | Boundary Details  Sources  Plot Options

Boundary Type Opening -

Location outlet w

[] Coordinate Frame




Qutline  Boundary: outlet 8
Details of outlet in Default Domain in Flow Analysis 1

Basic Settings | Boundary Details | Sources  Plot Options

Flow Regime S|
Option Subsonic -
Mass And Momentum =
Option Opening Pres. and Dirn -
Relative Pressure lo [Pa] |

[] Acoustic Reflectivity (Beta)
Flow Direction =i
Option Mormal to Boundary Condition -
] Loss Coefficient
Turbulence =
Option Medium (Intensity = 5%) <

Heat Transfer =
Option Opening Temperature v
Opening Temperature 120 [C] | |

10) Create boundary condition sym and apply the following settings

Outline  Boundary: sym
Details of sym in Default Domain in Flow Analysis 1

Basic Settings

Location | sym | v

11) Create boundary condition airfoil and apply the following settings
QOutline  Boundary: airfoil
Details of airfoil in Default Domain in Flow Analysis 1

Basic Settings Boundary Details Sources

Location I airfoil | “

[] Coordinate Frame




Outline  Boundary: airfoil (X
Details of airfoil in Default Domain in Flow Analysis 1

Basic Settings ~ Boundary Details ~ Sources

Mass And Momentum =]
(] wall Velocity
(] Turbulent Wall Functions (Beta)

Wall Roughness =]

Option Smooth Wall -

Heat Transfer =]

Option Adiabatic -

12) Create a monitor point containing expression with a definition: arealnt(Wall
Shear)@airfoil

13) Open Solver Control and apply the following
Outline

b @ Mesh
& sys.cmdb
@ Connectivity
b [EI Simulation
v |8 Flow Analysis 1
(D Analysis Type
v [v] & Default Domain
1% Default Domain Default
[PE inlet
ii outlet1
i$ outlet2
ﬁﬂ Interfaces
e Solver
&' Solution Units

EEG|".«'EF Control
Output Control
;gt. Coordinate Frames
User Locations
Transformations
@ Materials
@ Reactions



Outline Solver Control

Details of Solver Control in Flow Analysis 1

| Basic Settings |  Equation Class Settings

Advection Scheme

Advanced Options

Option High Resolution -
Turbulence Numerics =
Option High Resolution -
Convergence Control
Min. Iterations 10000 |
Max. Tterations 10000| 1
Fluid Timescale Control B
Timescale Control Auto Timescale -
Length Scale Option Conservative -
Timescale Factor 1.0
[] Maximum Timescale

Convergence Criteria
Residual Type RMS -
Residual Target 1.E-4

[ ] Conservation Target
[] Elapsed Wall Clock Time Cantraol
Interrupt Control =

14) Close Ansys CFX.

2.4. CALCULATIONS

1) Double-click Solution to run Ansys CFX Solver Manager
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2) Apply below settings and press Start Run. The program will perform
calculations. Wait a few moments for the message to complete the calculations.

W




& Define Run ? *

Solver Input File NCw5\Cw5_files\dpO\CFX\CFX\CFX.def | || =
Global Fun Settings
Run Definition Initial Values
Run Settings
Type of Run Full

Double Precisiunl
[] Large Problem

Parallel Environment =
Run Mode Intel MPI Local Parallel -
Host Name Partitions

desktop-1erkcpo 4

[ ] show Advanced Controls

Start Run Save Settings Cancel

3) Calculations take about 2 minutes. Watch the individual bookmark tabs as they
change. Pay special attention to the User Point tab, where the shear force on the
profile is shown. Steady state will be reached when the curve stabilizes, which
will occur after about 100 iterations. Additional iterations should be performed
until all residuals have stabilized. To terminate calculations, press the Stop
button at the top of the screen and confirm Yes.
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4) After completing the calculations, the program will display a confirmation

message.

5) Confirm OK and close Ansys CFX Solver Manager. Save project in Workbench.

2.5. RESULTS

1) Double-click LMB Results to run Ansys CFD Post and see the results.
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2) Create a plane perpendicular to the profile (parallel to the sym surface) and

show the contours of
Pressure
Absolute Pressure
Total Pressure
Velocity

Mach Number
Density

o o0 Tw



g. Temperature
h. Total temperature
i. Turbulence Kinetic Energy
J.  Turbulence Eddy Dissipation
3) Using areaAve calculate in a table:
a. Inlet velocity value
b. Inlet mass flow value
c. The value of the average surface temperature at airfoil
d. Average value of the variable Yplus at airfoil
4) Show contours of Yplus at airfoil surface
5) Display the power lines on the previously created plane
6) *Calculate drag and lift coefficients for the tested airfoil
7) Return to Ansys CFX Pre and change expression Re into 500 000 and repeat the
calculations and points 2)-6). Next the same for Re =5 000 000.

3. RESULTS TO BE INCLUDED IN THE REPORT
For Re =50 000, 500 000 and 5 000 000 (Note: if possible, it is best to combine
the results for comparison; e.g. Fig. 1. Pressure distribution in the plane
perpendicular to the airfoil, a) Re = 50,000, b) Re = 500,000, c) Re =
5,000,000):
1) Contours in a plane parallel to the surface sym:
Pressure
Absolute Pressure
Total Pressure
Velocity
Mach Number
Density
Temperature
Total temperature
Turbulence Kinetic Energy
J. Turbulence Eddy Dissipation
2) Put the results in the table:
a. Inlet velocity value
b. Inlet mass flow value
c. The value of the average surface temperature at airfoil
d. Average value of the variable Yplus at airfoil
3) Photograph of the Yplus variable at airfoil surface
4) Streamlines (photo).
5) Answer the question: Based on the analysis of the Yplus variable value, whether
the SST turbulence model used was selected correctly?

—SQ@ e o0oo

4. OPTIONAL TASKS
1. Perform calculations using a different turbulence model and compare the results.
2. Return to the Meshing module and compact the mesh (especially on the airfoil
surface). Increase the number of elements also on other edges. Check how it affects
the calculations and the value of the Yplus variable.

5. REFERENCES
[1] https://www.youtube.com/watch?v=xkEvS5eafCg&t=6s Access: 15.05.2020
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